Skip to content

记录阅读代码版本

docker镜像

提示

基于hyperf/hyperf:8.1-alpine-v3.18-swoole镜像环境

php版本

提示

php版本要求>=8.1.0

hyperf版本

提示

hyperf版本~3.1.0

启动命令

在命令行中输入以下命令启动项目

bash
docker run --name hyperf \
-v $PWD/skeleton:/data/project \
-w /data/project \
-p 9501:9501 -it \
--privileged -u root \
--entrypoint /bin/sh \
hyperf/hyperf:8.1-alpine-v3.18-swoole
# 其中 $PWD/skeleton可替换为自己的目录